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1 What is D2Inventory

D2Inventory is graphic user interface that make editing of inventory grid much easier. Main goal of this
program is to rise speed and accuracy of inventory grid editing. Also program is made to prevent some of
common errors.

D2Inventory preview.
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1.1 Features

Primarily purpose of D2Inventory is editing Inventories.txt. It support both classic and expansion versions
of file. Other features of D2Inventory are:

w Visual inventory grid overview.
Grid will be drawn on screen like it would be drawn in-game so you can easily make adjustments to
your desire. Graphic approach rise speed and accuracy of inventory grid manipulation. Also there is
no need to always restart game to see test latest changes. All changes is up to date instantly. 

w Load relevant inventory graphic
D2Inventory can load *.DC6 files relevant for correct inventory grid position. That include panels, tabs
and buttons on that panels. That make grid editing much faster then before. If graphic files isn't
specified program will use internal ones.
Graphic elements can be reloaded anytime that make D2Inventory ideal for fast game GUI editing.

w Common error checking
Some of common errors can be fixed automatically to speed up process of grid editing and to
remove repeating actions that can bring to mistakes or errors.
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1.2 License

D2Inventory is graphic user interface that make editing of inventory grid much
easier. Main goal of this program is to rise speed and accuracy of inventory grid

editing. Also program is made to prevent some of common errors.
Copyright (C) 2010 GameMaster.

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by

the Free Software Foundation, either version 3 of the License, or
any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of

MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.

1.3 Thanks

Thanks to Phrozen Keep community for all efforts in discovering of mod-making tricks and technics as
well as sharing tools made for one of greatest RPG games ever. Thanks to moders that still has interest
in moding and playing Diablo II despite fact that game is 10 years old. And thanks to Blizzard for making
such game. 

Special thanks to beta testers for bug finding, improving and suggestions:
M@JRIS
Paul Siramy

http://www.gnu.org/licenses/>.
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2 Starting

This part of manual will be focused on new users and users that use D2Inventory first time. It is
recommended to read this section at least once. Here will be explained how to install and configure
program.

System requirements: It is required resolution 1024x768 or greater for correct functionality of program.
D2Inventory work on Windows XP and it's not tested on other Windows versions. For manual preview is
needed Acrobat Reader 6 or greater.

2.1 Instalation

There is no need for any particular installation on Windows XP operating system. All is needed is to
unpack all files to same directory and D2Inventory is ready for use. If needed you can make quick
adjustments.

If you familiar with zip archive you can skip rest of chapter otherwise follow next steps to unpack
D2Inventory:
1. Download D2Inventory.zip to your Desktop,
2. Right click on it and Extract All...,

D2Inventory.zip. Location of "Extract All...".

3. In "Extraction Wizard" pres Next,
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Extraction Wizard.

4. Enter destination directory. e.g. "D:\D2Inventory",
5. Press Next then Finish,
6. After explorer open destination directory right click on D2Inventory.exe and go to Send to> Desktop

(create shortcut).

Creating shortcut to D2Inventory.

7. After this steps you should have something like this.

Done.
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2.2 Configuration

D2Inventory can work without any initial configuration but it is recommended to make few adjustments.
Adjustments can be done:

w Manually
All adjustments is stored in Options.ini file. Options.ini must be in same directory as D2Inventory's exe.
If application cant find ini then will be loaded internally. Also if some of parts of Options.ini is missing
then it will be used from internal configuration file. Manually editing of Options.ini offer much more
options then automatic mode.

w Quick
Quick adjustment offer just basic but most used configurations. You can set paths for palette, inventory.
txt, and working directory that contains all graphics. This options can be found in Tools>Quick
configuration... or with shortcut  F4 .

2.3 Terminology and convention

Here will be discussed some terminology used within manual. It is necessary for this because there are
great number of new terms and if you don't know what i referee it can make mess. This terminology is
internal and used for this manual only. You can use different terminology

w Inventory.txt
Is file from data\global\excel\ folder. It contain locations and size of clickable location on panels in
game. It is divided to 32 panels for expansion or 12 for classic game (16 after expansion is relised
because of 2 new classes and resolution increases). 

w Panel
Is main unit in Inventory.txt it contain information for corresponding panel. Each panel has 11 parts
called parts. After expansion is relised each entry got 800x600 counterpart. It has added "2" at the
end of name. (e.g. "Amazon" for classic and "Amazon2" for expansion). Marked as 1 on following
image.

w Parts
Is smaller part of each panel. It can be one of following: inv, grid, rArm, torso, lArm, head, neck,
rHand, lHand, belt, feet, gloves. "inv" part in D2Inventory will be refereed as "main". Marked as 2 on
following image.

w Slot
Is part of panel that hold equipment. It can be one of following: weapons, armor, belt, helm, boots,
gloves, rings and amulet. Only character and hirelings has slots. Marked as 3 on following image.

w Clickable area
Is area covered by "main" part of panel. Some panels don't use this parameter like hirelings and
transmogrifer. Marked as 4 on following image.
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w Covering area
Is hit test area for grid alone. Like inventory grid. It must be enough to cover entire grid. Covering
area is importent because he detect mouse hit and if it has wrong side mouse click can be ignored.
Marked as 5 on following image.

w Grid size
Is size of inventory in cells. Defined by gridX and gridY in expansion version and by gridRows and
gridCols in classic. Its located under "main" part. Marked as 6 on following image.

w px
Pixels. Dimension of measuring length on 2D images.

w Inventory grid
Part of panel that can store lot of items. Character inventory has that grid as well as shop, trade,
stash and other panels. Max value for grid is 16x16 cells.

w Cells
Dimension of inventory grid. e.g. 10x4 for character inventories.

w Working directory
Is path to directory that contain *.DC6 files for in-game interface. By default in your mod it will be .../
data/global/ui/panel.

w Toolbox
Its palette of tools located on right side on main window of D2Inventory. It contain Main controls,
Edits, Zoom, Options and Warnings. Each of this tools had shortcut associated with them and can
be found in main menu. Marked as 7 on following image.

w Resolution
Game has two resolutions 640x480 that is original resolution of classic game and 800x600 that is
introduced in expansion. In further text 640x480 will be referenced as low resolution and 800x600 as
high resolution. You can change it if use Inventory.txt with 32 panels.
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Explanation of some terms.

Bulletin in this manual will be separated in two kind. First is represented with little ( § ) black rectangle
filled with black color and it mean "do all in following list" and little rectangle filled with white color ( ú )
that mean "do some from following list". Other bulletin haven't any particular meaning. This is internal
convention and will be used furthermore.
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3 Interface

D2Inventory is divided in few sections. Short explanation of those section follows.

D2Inventory sections.

1. In-game preview
Contain in-game preview with all relevant elements for grid editing. Its main part of D2Inventory and
its consisted of 4 layers that can be turned on or off. 

2. Grid
This is just preview of currently edited grid. Sometimes is easier to follow changes in grid view then
in interactive preview. This section show all panels entry at once. Grid section is read only and data
cant be changed. Also expansion line is not displayed.

3. Panels
Panels are set of tools located on right side of form. Contain all needed tools for manipulating and
editing grid. Those tools can be accessed trough shortcuts and main menu. Panels will be explained
in next chapter.

4. Menu
Like all standard menus it contain easy access to all functions building program. Menu structure will
be explained later.
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3.1 Toolboxes

Toolboxes are tools located on right side of form. Most used commands are located here. You can fold
or unfold it by clicking on name or by specified shortcuts. 

3.1.1 Main Controls

Main controls toolbox are first in list. It contains tool relative to selection desired panel to edit. Shortcut
to this toolbox is  F5 .

Main controls.

Game
Some panels has different images in classic and expansion games. Here you can switch between
those display. If you load old Inventory.txt from pre expansion versions ( that has less number of
rows ) then Expansion preview will be disabled. It is important to know that Inventory.txt in all version
after expansion is released contains information about both classic and expansion inventories. 

Resolution
Classic was designed in 640x480 resolution. With expansion release Blizzard add higher resolution
to game. To avoid remaking entire interface graphic they decide to keep it and just move it to center
of screen and put border around. In high resolution all clickable areas are moved by 80,60px from
top-left edge of screen. By main controls' resolution option you can preview inventory in different
resolutions. Options is disabled when load old Inventory.txt.

Panels
Inventory.txt is consisted of 32 panel (or 12 in old versions). Each panel has name and is used in
different place in game. Here you can select current panel. Current panel is panel that is edited by
all tools in tool palette.

Layers 
Layers are parts of in-game preview image. It can be turned on or off regardless of need. Preview are
organized by layers to give you greater  flexibility when edit or test inventories. There is list of layers:
w Border

It contains frame around screen in high resolution. Can be disabled if you need some better
preview of background otherwise it should be on.

w Panels
Most important part of D2Inventory. It contains actual images of panels.

w Bar
Contain bar and all necessary images relative to them. 
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w Grid
Show or hide display of editable grid. It can be disabled if you need to have clean preview of all
graphic elements. When grid is enabled you cant interact with clickable elements like buttons
and tabs.

3.1.2 Edits

Edit toolbox contain tools used to move or resize any part of panel. Shortcut to this toolbox is  F6 .

Edits.

Left, Right, Top, Bottom
In game specify distance from top-left corner of screen to edge of part. Those distance can be
negative number but then it will be out off screen. Keep in mind that Right and Bottom isn't
measured from Left and Top point of part. Its measured from top-left point of screen. Because of that
Right and Bottom is always greater then Left and Top.

Height, Width
It is height and width of part. This value is read only. If you select "main" part this edits will not refer
to parts height and width. Instead of that it will contain number of column and rows in inventory grid.
In that case it will be called "gridX" and "gridY". If you select "grid" part then Height and Width
referee to Cells' height and width. Default cell dimension is 29x29px.

Part
All panels consist of 12 parts. Those parts are: grid, rArm, torso, lArm, head, neck, rHand, lHand,
belt, feet, gloves. 
Part is defined with 4 points Left, Right, Top, Bottom. There are redundant value of Height and Width
which must be Height=Bottom-Top and Width=Right-Left. Exception is "main" and "grid" part which
use that value for inventory grid dimension and cell size.

3.1.3 Zoom

Zoom toolbox can be very useful when you need to make little adjustments and cant see what's actually
append. Shortcut to this toolbox is  F7 .
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Zoom.

X, Y
Current cursor position on In-game preview. That's pixel is surrounded by green rectangle. Green
rectangle can be disable in Options toolbox.

Zoom level
Three different zoom levels, X2, X4, X8.

3.1.4 Options

Contains some quick options that can be usefully in some situations. Shortcut to this toolbox is  F8 .

Options.

Both border always
This option force drawing both border in higher resolution. Border is consisted of two part left and
right. Each cover panel on that side. By default border is drawn only around current panel. Its game-
like behaviour.

Hide buttons on panels
When checked prevent drawing buttons on panels. It is useful when you need to see only panel
without interference of other elements.

Hide item backgrounds
Item backgrounds are images that placed on item slots when they are empty. It is useful when you
need to see only panel without interference of other elements.
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Hide NPC tabs
Hide tabs on shop panel.

Draw info
When On this option display location and size of dragging part during resizing or moving with
mouse. Information is displayed near mouse cursor. By default this option is on.

Zoom rectangle
Disable drawing green rectangle in Zoom toolbox. By default this option is on.

Prevent Moving
Prevent moving of part. Very useful when you need only resize parts but keep current location. It can
prevent accident moving of panel. Its ignored by keyboard.

Prevent Resizing
Prevent resizing parts. Useful to prevent accidental part resize. Its ignored by keyboard.

Life and mana orb
Slide bar regulate current amount of life and mana in orbs. It can be used to test your custom orbs.

Poisoned
If on then health orb will be poisoned.

Unused 
If checked it will draw 4th orb graphic over mana orb. It is not used in game. Left for test purpose
only.

3.1.5 Warnings

Contain warnings relative to incorrect grid dimensions. There are list of panels that has error. Double
click on panel name will open list of errors. Double click on error will focus selected panel. List of all
errors are given in Appendix A - Warning messages. Shortcut to this toolbox is  F9 .

Warnings.
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3.2 Menu

All tools and commands can be accessed trough main menu. There are list of menus and their contents.

3.2.1 File

File menu contain common operations with Inventory.txt.

File menu.

New
Will create new Inventory.txt to target location. It file will be unmoded Inventory.txt from game. You
can chose between classic and expansion version of file. Classic file will be pre-expansion version.
After creating new file will be loaded automatically. Be careful and save all needed changes before
create new file. Shortcut is  Ctrl+N .

New... dialog.

Open
Will open existing Inventory.txt from target location. Unsaved data will be lost. Shortcut is  Ctrl+O .

Save
Will update current opened file with all modifications. Shortcut is  Ctrl+S .

Save As
Will save current file with different name. Shortcut is  Ctrl+N .

Quit
Here you can exit D2Inventory. You can also exit program by  ESC  or by accelerated key  Alt,F,Q .
Shortcut is  Alt+F4 . 

Recent files
There are list of 10 recent used files. Each time you make new Inventory.txt or open existing one, as
well as save to another file or configure settings with "Quick configuration", used file will be added to
recent list. Even when you load item from recent list current used files will be added to list. Shortcut
is  Ctrl+0 .. Ctrl+9 . Invalid entries will be removed from list on startup. You can clear list by delating
 entries from Options.ini file.
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Note: Do not modify Recent files in Options.ini if you don't know exactly what you doing.

Recent used files.

Recent list contain 
Txt - Shortened path to used Inventory.txt file,
Dir - Location of all *.DC6 files used to generate inventory,
Plt - Used palette. This path may be blank when internal palette are used.
Date - Date and time when item is added to list.

3.2.2 Edit

Edit menu has common edit options

Edit menu.

Undo
There is 100 undo levels. D2Inventory will track resizing and moving parts manually as well as using
Fix grid tool and Copy inventory tool. History will be erased after open or loading new Inventory.txt.
or by setting new file paths in Quick configuration. Shortcut is  Ctrl+Z .

Redo
Redo can be used after undo to revert last undo. Shortcut is  Ctrl+Y .  

Reload
Reload graphic elements and/or Inventory.txt. Its useful when you change those elements from
another program. e.g. you can edit inventory.txt in Excel and simple reload it or after editing DC6
image in another program reload it to update current used graphic. Care, unsaved data will be lost.
Shortcut is  Ctrl+N .

Reload... dialog.
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3.2.3 View

View menu show or hide toolboxes. By default Main controls and Edits are shown.

View menu.

3.2.4 Tools

Tool menu contain another group of useful commands.

Tools menu.

Copy inventories
Those tool allow easy copy of whole panel to another panel in same resolution or between
resolutions. Usage of those tool is displayed in next chapter. Shortcut is  F2 .

Fix grid
Allow you to quick fix grid covering and grid size errors or set all grid size at once. Usage of those
tool is displayed in next chapter. Shortcut is  F3 .

Quick configuration
Most used configuration can be accessed here. Those options are paths to palette, graphic and
Inventory.txt. Also here you can export internal Options.ini in case of corruption current one. Usage
of those tool is displayed in next chapter. Shortcut is  F4 .

3.2.5 Help and ?

Help menu contain link to manual.

Help menu.

You can use manual from D2Inventory directory directly. To access manual trough this link manual must
be in  D2Inventory root or Tutorials directory. Also it must be named "User's Manual.pdf". To run manual
you need installed Acrobat Rider.
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3.2.6 ?

? menu contain about dialog and licence agreement.

? menu.
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3.3 Tools

There will be described usage of 
w Copy inventories, 
w Fix grid, 
w Quick configuration tools.

3.3.1 Copy inventories

Those tool is located in Tools>Copy inventories... alternatively you can access it by shortcut  F2 . 

Copy inventory tool.

Copy inventories tool will copy panel defined by resolution and source to target group of panels and will
make adjustments on target panels defined in offset. Main purpose of this tool is when you make one
panel you can copy it to another resolution or to another panel in same resolution. Imagine editing seven
character inventories in two resolutions, why not edit one and copy it to all others. It will save tame and
will prevent errors.

Resolution
Its resolution that contain source panel. Changing those will update Source panels to all available
panels for selected resolution.

Source
Is panel that is base for coping.

Target
Target can be:
w Same panel in other resolution

It will make panel from another resolution same as selected one and it will be moved for offset
value. e.g. Amazon panel (classic) can be made from Amazon2 (expansion) if you move move it
by 80,60px (it is dimension of boarder).
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w All inventories in this resolution
This will make all character inventories same in current resolution. To activate this option you
must select character inventory. e.g. Edit Amason2 and make all character inventories in hight
resolution same.

w All inventories in all resolution
This will make all character inventories same in both resolutions. To activate this option you
must select character inventory. e.g. Edit Amason2 and make all character inventories same.
This option is useful when modify character inventories.

Offset
Is used when make one inventory with another from different resolution. In original Inventory.txt all
high resolution inventories are same as low resolution one but they are moved by 80,60px.

3.3.2 Fix grid

Those tool is located in Tools>Fix grid... alternatively you can access it by shortcut  F3 . 

Fix grid tool.

Fix grid tool will help you to fix inventory grid that has inappropriate covering area. Covering area should
be exact as number of cells multiplied by cell size. If area is smaller then mouse click can't be
recognized, if area is too big it can cover another element and click wont be passed to it. Right part of
tool will make inventories in both resolutions same. It is important because game will make minimal grid
from both resolution. e.g. Classic grid is 10x4 and expansion is 6x5 final grid will be 6x4. Most common
error is edit one panel and forget to edit same panel in different resolution. Another important thing is that
"Grid covering box" display only panels that has found errors while panes without error are omitted.

Grid covering
Here will be listed panels that has invalid size. Check one you want to correct and D2Inventory will
recalculate covering grid for you. You can select or deselect all panels at once with two buttons
bellow. 
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Grid size
This tool will help you to make all selected panels same size as smallest one. You can select or
deselect all panels at once with two buttons bellow.

Make all inventories same
If this checkbox is checked then all inventories will have size defined in edits bellow.

3.3.3 Quick configuration

Those tool is located in Tools>Quick configuration... alternatively you can access it by shortcut  F4 . 

Quic configuration tool.

Here you can change tree most important settings for D2Inventory. Those settings can be set manually
in Options.ini. With "C" button you can clear entry to default value.

Palette
Location of file that contain colors used to decode DC6 image. This file can be *.Dat or *.PL2 file. If
not specified or invalid will be used internal Act1 palette.
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Working directory
Is location that contain all needed images for inventory drawing. It is something like .../data/global/ui/
panel. Missing or incorrect data will be loaded from internal source. In next table is list of all relevant
graphic files.

from Classic from Expansion

bank.DC6 800BorderFrame.dc6

ctrlpnl7.DC6 800ctrlpnl7.dc6

buysellbtn.DC6 buysellbtn.dc6

buyselltabs.DC6 invchar6.dc6

buysell.DC6 invchar6Tab.dc6

ctrlpnl_popbelt.DC6 level.DC6

goldcoinbtn.dc6 NpcInv.dc6

guildvault.dc6 TradeStash.dc6

hlthmana.DC6

inv_armor.DC6

inv_belt.DC6

inv_boots.DC6

inv_helm_glove.DC6

inv_ring_amulet.DC6

inv_weapons.DC6

invchar.DC6

levelsocket.dc6

miniconvert.DC6

overlap.DC6

runbutton.dc6

supertransmogrifier.dc6

trade.DC6

trophycase.dc6

Inventory.txt location
It is location of Inventory.txt file you edit. If not presented or can't be loaded will be used internal file
from 1.11b version.

Export Options.ini
In case you have corrupted or missing Options.ini file you can export it from this tool. Exported file
will have just most basic sections unless uncheck "Detailed" checkbox. It is recommended for most
user to use basic Options.ini file and to not make manually changes.



Interface 22

© 2010 GameMaster

4 Tutorials

Best way to demonstrate D2Inventory ability is to see it in work. Here is few tutorials ranged from
simplest to much complicated one. Tutorial are made to cover most D2Inventory functionality. All needed
data for tutorials can be found under Tutorials sub folder of D2Inventory. It is not recommended to save
output file over existing one in tutorials because you wont have clear file next time you do tutorial. In
case of corrupting or missing files just unpack it again from archive.

There are 3 tutorials:

w Tutorial 1 : Introduction
Mean goal of this one tutorial is to introduce basic interface and give example of D2Inventory
capability.

w Tutorial 2 : Extra space
Here will be explained how to adjust inventory to new image and how to copy inventories.

w Tutorial 3 : More space
Example of recreating "Collectors_backpack" plugin.
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4.1 Tutorial 1 : Introduction

4.1.1 Goal

This first tutorial will introduce you to D2Inventory basics and explain most basic operations. This tutorial
is base for all others tutorials.

Tutorial level:
w Basic.

Goal of tutorial:
w Locate and manually fix all known incorrections in Inventory.txt from version 1.11b,
w Introduce to D2Inventory interface and functionality,
w Using of Fix grid tool.

4.1.2 Preparations

Start D2Inventory and fallow next steps.

1. Quick configure all necessary paths that contain relevant files.
Before start you must specify location of all relevant files. To do this you can manually change
Options.ini or use quick configurations witch contain only most important and most used options.

1.1. Open quick configuration menu.
Quick configurations can be opened from menu or by associated shortcut.
ú Go to Tools>Quick configurations... from main menu, or 
ú Use shortcut  F4  to open it.

Location of Quick configuration.

1.2. Set location of Inventory.txt.
Depending of location where is D2Inventory located you should have something like this 
<D2Inventory location>\Tutorials\Tutorial01\Inventory.txt.
§ Press  ...  to select location of Inventory.txt from tutorials directory.
§ Confirm change with  Ok  to close dialog.
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Quick configuration dialog.

2. Confirm update.
After changing paths it will be saved to Options.ini and it will NOT have immediately effect on future
work of D2Inventory until restart. After cofirm changes in quick configuration you can reload all
relevant files for changes to take effect. 
§ Then you will see next message. Answer with "Yes" to reload D2Inventory options. 

Update dialog.

That's all needed configurations for this tutorial.

4.1.3 Work

To fix problems with Inventory.txt we first need to found problems. Some of first questions can be
"Where is problem in file that work ok for 10 years ?". Ofcours that problem is not critical otherwise it will
be spotted.

1. Find problems.
You can go from panel to panel and check manually witch one has incorrections or just use Analyse
tool in combination with Warnings panel.

1.1. Open Warnings panel.
By default Warnings panel is collapsed so you need to expand it.
ú Go to View>Warnings from main menu or 
ú Click "Warnings" panel or
ú Use shortcut  F9  to open Warnings panel.
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Note: Warnings will not be updated if Warnings panel is expanded and you make changes on
any part. Best way is to update it manually each time you use it. To update warnings anytime
you can do it: 
ú Go to View>Analyse from main menu or 
ú Use shortcut  F12  to open it.

1.2. Select panel.
For demonstration we will use "Amazon2" panel. In Warnings panel scroll down to "Amazon2",
which contain errors related to amazon inventory in high resolution, and double click it.

Warnings panel.

As you can see we have warnings here. For warnings descriptions see Appendix A - Warnings
messages. This warning tell us that something wrong with grid size and covering area of that
grid. If you look carefully you will see that grid is not covered entirely by covering area. Last row
and last column is just 26px long. 

Last row and colum is not 29 px as all other cells.

Note: Double click on error will select panel as current. e.g. double click on "Grid not covered."
will make "Amazon2" panel as current one. 

2. Fix problem.
To fix this problem we have two options: 
ú Fix it manually or 
ú Fix it automatic.
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2.1. Manually.
For manually editing we must first do some math. How big should covering area be to cover
entire grid? If our grid is 10x4 cells and each cell should be 29x29px then we need 290x116px
covering area, we have 287x113px. To fix that we need just resize area by 3x3 px. But wait, it is
not all. Duo Blizzard's infamous incorrect coding character inventories must be 1px smaller then
it should be or it will cause annoying crash. It apply only on character inventories. This edit can
be done on 3 ways:
ú Simple grab bottom right corner and make W:289 H:115 or

Covering area before resizing. Covering area after resizing.

ú Use Edit panel and increase Right and Bottom by 2,
To open Edit panel do
ú Go to View>Options from main menu or
ú Click "Edits" panel or
ú Use shortcut  F6  to open Edit panel.

Edit panel before edit. Edit panel after edit.

ú Use  Ctrl+Right  to increase width and  Ctrl+Down  to increase height.

Now analyse grid again ( F12 ) and try to find "Amason2" in Warnings panel. Ofcours there is no
such entry because no error is found. That is manually way to fix common error with incorrect
grid covering. Like you can see all panels has same problem, except hireling's panel. To fix all
that problems just repeat same process to all panels.

2.2. Automatic.
If you don't want do all that job manually you can use tool for that. You can access tool:
ú By Tools>Fix grid from main menu or
ú Use shortcut  F3  to open it.
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Location of Fix grid.

It will open Fix grid tool. On left side is group of controls called Grid covering. That group of
controls can fix covering errors for selected panel. Just select all panels pressing  Select all
 and after that press  Fix . Then exit dialog with  Cancel .

Fix grid covering dialog.

3. Save Work.
To save fixed Inventory.txt just go to File>SaveAs or press  Ctrl+A .Then select file location to save.
You can save this file over old one File>Save or press  Ctrl+S . It is not recommended because
tutorial's file will be changed and you will not have valid file for this tutorial if you decide to do it
again.
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4.2 Tutorial 2 : Extra space

4.2.1 Goal

This tutorial will be focused on character inventories, stash and transmogrifier from 800x600 only. To
complete this tutorial you must understand Tutorial 1.

Tutorial level:
w Basic.

Goal of tutorial:
w Show how to adjust inventory to new inventory image,
w Using Options and Zoom panel,
w Using Copy inventories tools.

4.2.2 Preparations

Start D2Inventory and fallow next steps.

1. Quick configure all necessary paths that contain relevant files.
1.1. Open quick configuration menu ( F4 ).
1.2. Set location of Inventory.txt.

<D2Inventory location>\Tutorials\Tutorial02\Inventory.txt.
1.3. Set location of  working directory.

<D2Inventory location>\Tutorials\Tutorial02.

Quick configuration dialog.

2. Confirm update.

That's all needed configurations for this tutorial.
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4.2.3 Work

As you can see something is wrong with grid. Grid not cover image correctly. It is because we use
Inventory.txt from 1.11b version and its image is modified version of original one. All we need to do is
adjust inventories according to image for all panels.

In-game image.

1. View preparation.
1.1. Find Options panel: 

To make image view cleaner and easy to use we will disable all elements not relevant for this
tutorial. To open panel do 
ú Go to View>Options from main menu or 
ú Click "Options" panel or
ú Use shortcut  F8  to open Options panel.

1.2.Set options: 
From panel check three checkbox like on image. It will prevent drawing inventory slot
backgrounds and buttons.
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Options panel.

1.3. Prepare Zoom.
Second helpful thing in this tutorial is zoom. There are 3 zoom level available to use. Chose one
depending of situation and your need. 
Zoom x2 is especially good if you need to enlarge info during grid moving or resizing. Zoom
panel contain X and Y coordination of current mouse position. To access panel:
ú Go to View>Options from main menu or 
ú Click "Zoom" panel or
ú Use shortcut  F7  to open Zoom panel. 

Zoom panel.

2. Selecting part.
We must manual place all elements on its place. Lets start with "rArm" part of "Amazon2" panel
which is actually weapon slot on left side.

2.1. Selection from Edit panel.
Just open Edit panel and select part "rArm"

2.2. Select from In-game preview.
Alternate way to do this is click on part on in-game preview.
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Selection rArm part. In-game preview.

After selecting "rArm" part Height and width will be disabled. As result in-game frame will be
marked as green and edit panel will be updated with new informations.

3. Adjusting parts location and size.

3.1. Part "rArm"
To adjust location simple drag part to its location then resize it. Each weapon slot should be
2x4 cells in size if cell is 29x29px then we need 58x116px. Keep in mind that basic block is
29x29px in size and slots should have size: 2x4, 2x3, 2x2, 2x1, 1x1.  

Start drag location. End drag location. Resize to corect size.

3.2. Other parts.
Do same as above for all other parts listed in table.

Part
Position Size (cells) Size (px)

X Y Width Height Width Height

torso 533 135 2 3 58 87
lArm 640 87 2 4 58 116
head 533 64 2 2 58 58
neck 602 93 1 1 29 29
rHand 492 237 1 1 29 29
lHand 606 237 1 1 29 29
belt 534 237 2 1 58 29
feet 649 210 2 2 58 58
gloves 418 210 2 2 58 58
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4. Adjust grid location and size.

4.1. Positioning grid:
Grid must be moved to new location based on new image. To position grid drag it to 418,272. Its
new origin of grid.

4.2. Increase number of rows:
Change part to "main" and set gridY to 6.

Edit panel.

4.3. Adjust covering area:
Select "grid" part again and make size 289x173px. Its last step in adapting "Amason2" grid to
image. 
After all edits in-game preview should look like this:

Look of Amason2 panel after all edits.
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5. Adjust others grids and size: 
It is needed to edit other 6 inventories (Sorceress2, Necromancer2, Paladin2, Barbarian2, Druid2,
Assassin2) like this one. It can be done repeating steps 2 to 4 for each inventory. If you don't want
to do it manually D2Inventory can do it for you.

5.1. Open copy inventories dialog:
To open dialog you can
ú Go to Tools>Copy inventories... in main menu or
ú Use shortcut  F2  to open copy inventories dialog.

Select "All inventories in this resolution" to make all inventories in 800x600 resolution same as
source one. That will make expansion inventories same (as currently selected one) for all
character.

Copy inventories dialog.

5.2. Apply changes.
Confirm changes with Yes then exit Copy inventories tool.

Confirmation dialog.



Tutorials 34

© 2010 GameMaster

6. Adjust Transmogrifier and Stash.

6.1.Transmogrifier
Follow next steps to adjust transmogrifier: 
§ Select "Transmogrity Box2" panel,

Select Tranmogrify Box2.

§ Select "main" part,

Select main part.

§ Change Height to 8 and  Width to 10,
§ Select "grid" part,
§ Drag it to 96,76
§ Resize it to 290x232px.

6.2.Stash:
Last part is to adjust stash grid. Follow next steps to adjust it:
§ Select "Big Bank Page2", 
§ Select "main" part,
§ Change Height to 10 and Width to 10,
§ Select "grid" part,
§ Drag grid to 96,144 
§ resize it to 290x290px. 

After all edits in-game preview of transmogrifier and stash should look like this:
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Transmogrifier look after edits. Stash look after edits.

7.  Save Work:
Save Inventory.txt to another file File>SaveAs or press  Ctrl+A  like in Tutorial 01.
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4.3 Tutorial 3 : More space

4.3.1 Goal

This tutorial will be focused on character inventories, shop panel, trade panels, transmogrifier, stash and
hireling panel from 800x600 only. To complete this tutorial you must understand Tutorial 1 and Tutorial 2.

Tutorial level:
w Advanced.

Goal of tutorial:
w Show how to adjust inventory to new inventory image that use different cell size.

4.3.2 Preparations

Start D2Inventory and fallow next steps.

1. Quick configure all necessary paths that contain relevant files.
1.1. Open quick configuration menu ( F4 ).
1.2. Set location of Inventory.txt.

<D2Inventory location>\Tutorials\Tutorial03\Inventory.txt.
1.3. Set location of  working directory.

<D2Inventory location>\Tutorials\Tutorial03.

Quick configuration dialog.

Note: Pay attention to content of Tutorial03 directory. There are all modified files that comes
with "Collectors_backpack" plugin. D2Inventory will  automatically load all necessary graphic
from it.

2. Confirm update.

That's all needed configurations for this tutorial.
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4.3.3 Work

Start preview should look like this. As you can see greed did not fit to background image. Like last time
its because we use standard Inventory.txt from 1.11b. To fix this proble we need to adjust grid for
character inventories, shop panel, trade panels, transmogrifier, stash and hireling panel. 

In-game image.

1. View prepare
Turn on Zoom panel  F7  because we will need extra precision.

2.  Character's panels.
Lets start with characters's panels. If not selected "Amazon2" select ti.

2.1. Set grid dimensions.
First we need to set character inventory to size 16x14 cells. Select "main" part and set:
§ gridX to 16,
§ gridY to 14.

Next, select "grid" part and set:
§ Width to 16,
§ Height to 16,
§ Left to 432,
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§ Right to 687,
§ Top to 204,
§ Bottom to 427.
This will make each cell in grid to change size from 29x29px to 16x16px.

Note: To easier adjust position and size you can use keyboard. Arrows keys to move and  Ctrl
+Arrows  to resize currently selected part.

2.2. Correct all parts.
Now we need to do same for all other parts. Set positions and size to all part listed in table:

Part
Position Size (px)

Left Right Top Bottom Width Height

rArm 482 514 90 154 32 64

torso 545 577 105 153 32 48

lArm 607 639 90 154 32 64

head 545 577 68 100 32 32

neck 584 600 82 98 16 16

rHand 522 538 161 177 16 16

lHand 584 600 161 177 16 16

belt 545 577 161 177 32 16

feet 607 639 161 193 32 32

gloves 482 514 161 193 32 32

Note: Size (px) is calculated according formula: Width=cells in row * cell width, Height=cells in
column * cell height. e.g. torso is 2x3 cells in size and one cell is 16x16px in size that is give
us 32x48px in total.

2.3. Copy inventory to other character inventories.
Last part of editing character inventories is to make them same. To make all other character
inventory same just copy "Amazon2" over them. To do that follow next steps:
§ Select "Amazon2" panel if not selected,
§ Go to "Copy inventories tool" pressing  F2 ,
§ For "Target" set "All inventories in this resolution",
§ Apply and confirm changes,
§ Close tool.

Characte'r inventory before edit. Character's inventory after edit.
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3. Hireling panel.
Hireling panel has name "Hireling2" for high resolution. Here we need move and adjust weapons,
armor and helm slots.
First we need to set grid cells size to 16x16px. Select "Hireling2" panel if not selected then go to
"grid" part and set:
§ Width to 16,
§ Height to 16.

After that do following changes:

Part
Position Size (px)

Left Right Top Bottom Width Height

rArm 161 193 90 154 32 64

torso 224 256 105 153 32 48

lArm 286 318 90 154 32 64

head 224 256 68 100 32 32

Hireling inventory before edit. Hireling inventory after edit.

4. Shop panel.
Shop panel for high resolution is stored under name "Monster2". It is our next target. We need just
resize grid and position it to correct position. To accomplish this follow next steps:

Set inventory to size 16x16 cells. Select "Monsters2" panel if not selected then go to "main"
part and set:
§ gridX to 16,
§ gridY to 16.

Next, select "grid" part and set:
§ Width to 16,
§ Height to 16,
§ Left to 87,
§ Right to 343,
§ Top to 123,
§ Bottom to 379.
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Shop inventory before edit. Shop inventory after edit.

5. Trade panel.
Trade panel is composed of two panels. One for you and one for allay you treading with. Upper panel
is your panel and it has name "Trade Page 1-2" for high resolution. This panels has only grid and
like with shop panels we need just to move and resize it. 

5.1. Your panel.
Follow next steps to your adjust panel:
§ Select "Trade Page 1-2" panel if not selected then go to "main" part and set,
§ gridX to 16,
§ gridY to 7.
§ Select "grid" part and set,
§ Width to 16,
§ Height to 16,
§ Left to 114,
§ Right to 370,
§ Top to 100,
§ Bottom to 212.

Trade inventory before edit. Trade inventory after edit.
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5.2. Allay's panel.
Follow next steps to adjust allay's panel:
§ Select "Trade Page 2-2" panel,
§ gridX to 16,
§ gridY to 7.
§ Select "grid" part and set,
§ Width to 16,
§ Height to 16,
§ Left to 114,
§ Right to 370,
§ Top to 316,
§ Bottom to 428.

Trade inventory before edit. Trade inventory after edit.

6. Horadric cube.
Horadric cube has name "Transmogrify Box2" in high resolution. Like last 2 panels it need
positioning and resizing. Select "Transmogrify Box2" panel and follow steps:
§ Select "main" part and set:
§ gridX to 16,
§ gridY to 16,
§ Select "grid" part and set,
§ Width to 16,
§ Height to 16,
§ Left to 112,
§ Right to 368,
§ Top to 63,
§ Bottom to 319.
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Horadric cube inventory before edit. Horadric cube inventory after edit.

7. Stash.
Same as above. Move grid and resize:
§ Select "Transmogrify Box2" panel and go to "main" part and set,
§ gridX to 16,
§ gridY to 16,
§ Select "grid" part and set,
§ Width to 16,
§ Height to 16,
§ Left to 88,
§ Right to 344,
§ Top to 143,
§ Bottom to 399.

Stash inventory before edit. Stash inventory after edit.

8. Save Work: 
Save Inventory.txt to another file File>SaveAs or press  Ctrl+A .
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5 Appendix A - Warning messages

Warnings toolbox is used for fast diagnostic of inventory conditions and for finding most common errors.
It is recommended to update warnings each time you make changes on grid (and need warning
information ofcorse). It can be accessed manually from Tools>Analyse or by shortcut  F9 . That warning
can be ignored if you know exactly what you doing.

Here will be explained all recognized warnings:
w No grid.

Grid has height and/or width equal to 0. This error indicate that character inventory is disabled and
you wont be able to pick items from ground, except auto-equip items (potions to belt, gear if not
equipped ...). Note that decreasing size of inventory will lead to loss of items that is stored out of
grid new grid. That mean if you set inventory size 0x0 and start game you will lose all items
unrecoverable. If set shop grid to 0x0 it will prevent NPC from selling items as well as gambling. You
still can sell you stuff to them 

No gid.

Ignore this warring if you plan to make mod without character inventory or shop inventories.

w Invalid grid size (AxB), Must be CxD.
Indicate that selected inventory has bigger inventory grid then one in another resolution. By default
game will take smallest one for use in-game. e.g. you have 10x4 Amazon2 inventory size and 8x5
Amazon inventory grid size in both cases when you start game Amazons inventory will be 8x4,
smallest possible. For safety reasons is best to keep them equal. In next image Amazon2 panel
has size 10x10 and Amazon 10x4, game will use smaller one for both resolutions.

Amazon2 grid is greater then Amazon.

To fix this warnings you can use Fix grid tool.
Do not ignore this warning.

w Unselected area:
Indicate that part of panel is not covered entirely by clickable area. If part is completely out of area it
can't be accessible in-game because it will not get mouse hit. It is best to take entire part in
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clickable area. In next image first column of items will not be accessible because its outside
clickable area.

Inventory grid outside clickable area

of panel.

Ignore this warning if you sure that part can be accessed in-game.

w Grid not covered:
Indicate that grid size is not covered by covering area. If grid is greater then grid frame some items
from inventory will not be clickable. That mean that item can be auto-picked but cant be dropped
from inventory. In next image inventory 3x3 has much greater covering area then it need. In character
inventory covering area must be 1px less then it should be or it will course crash. e.g Inventory with
10x4 cells and cell size 29x29px should be 289x115px. This error occur only in character
inventories.

Grid 3x3 is smaller then covering

grid.

To fix this warnings you can use Fix grid tool.
Do not ignore this warning for character inventories. You can ignore this warning for other panels if
you sure that grid size is entirely covered.

w Overlaps:
Inventory slots are overlapped. It mean that you put one part over another. It is not recommended
because it can cause trouble during item equipping or placing in inventory. In next image torso part
overlap other three.
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Overlaped parts. Warning display.

Do not ignore this warning.
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6 Appendix B - Shortcuts

Here is list of all shortcuts in D2Inventory. Knowing some of this can rise speed of editing and save time
for another actions. Some of this option are used often and accessing them by shortcuts can be
advantage.

General shortcuts:
Shortcut: Description:

 Esc  Close current opened tool or exit program if no tool opened.
 Alt+F4  Exit D2Inventory
 Alt,F,Q  Exit D2Inventory

Menu shortcuts:
Shortcut: Menu location: Description:

 Ctrl+N  File>New... Create new Inventory.txt
 Ctrl+O  File>Open... Open another Inventory.txt
 Ctrl+S  File>Save... Save current Inventory.txt
 Ctrl+A  File>Save As... Save current Inventory.txt to another name and reload
 Ctrl+Z  Edit>Undo... Undo
 Ctrl+Y  Edit>Redo... Redo
 Ctrl+R  Edit>Reload... Reload current Inventory.txt
 F1  Help>Manual... This manual
 F2  Tools>Copy inventories... Copy inventories tool
 F3  Tools>Fix grid... Fix grid tool
 F4  Tools>Quick configurations... Quick configurations tool
 F5  View>Main control Show/hide main controls toolbox
 F6  View>Edits Show/hide edits toolbox
 F7  View>Zoom Show/hide zoom toolbox
 F8  View>Options Show/hide options toolbox
 F9  View>Warnings Show/hide warnings toolbox
 F11  Edit>Update Grid Update Grid panel 
 F12  Edit>Analyse Analyse warnings

In-game preview shortcuts:
Shortcut: Description:

 Left Arrow  Move current selected part 1px left
 Right Arrow  Move current selected part 1px right
 Up Arrow  Move current selected part 1px up
 Down Arrow  Move current selected part 1px down
 Ctrl+Left Arrow  Decrease current selected part width by 1px
 Ctrl+Right Arrow  Increase current selected part width by 1px
 Ctrl+Up Arrow  Decrease current selected part height by 1px
 Ctrl+Down Arrow  Increase current selected part height by 1px
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